Brainsight 2.2.14 is released for all users

We are happy to announce the availability of Brainsight 2.2.14.

Before proceeding with this update, please read the following important information.

Minimum requirements:
– Mac OS X 10.6 Snow Leopard is the absolute minimum version supported, but is strongly discouraged because it has a bug that can cause project saving to fail.
– Mac OS X 10.9 or later is strongly recommended. For a free update, visit <http://www.apple.com/osx/how-to-upgrade/>.

Changes since 2.2.13:
РAdded support for model 3 of our EMG Pod amplifier. Unfortunately, there’s no way for Brainsight to detect which model you have connected and so you must indicate to Brainsight by choosing your model in the Preferences window. As of today, everybody has model 2, but we are starting to make model 3 available to customers that want the retrofit.
– Fixed a bug where exported LOCATOR .elp files were not correctly formatted, resulting in problems importing them into other software.
– Fixed a bug where newer versions of the Keyspan driver were incorrectly detected as old, resulting in a warning at launch.
– Fixed miscellaneous bugs.

Note to 2.3 beta users:
– if you are already using a beta version of Brainsight 2.3, you should stay with that and ignore this email.

Download:
– You can download 2.2.14 just like any version of Brainsight, from our downloads section here

You’ll need your serial number, which you can get from Brainsight itself from the Brainsight menu > ‘Enter Serial Number’.

Installation:
– Simply run the downloaded installer, it will update any existing installation of Brainsight.

Should you encounter any difficulties, or have any questions, contact us at <support@rogue-research.com> or by phone at +1-866-984-3888 (Canada & USA) or +1-514-284-3888.